Go Back   Access World Forums > Microsoft Access Discussion > Reports

 
Reply
 
Thread Tools Rate Thread Display Modes
Old 11-25-2019, 11:16 AM   #1
Pauly D
Newly Registered User
 
Join Date: Nov 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Pauly D is on a distinguished road
Subreport calculation issue

I have a report with a sub report that used the following calculation:

=Round([Reports]![SetOC]![UpStartFreq]+[Spacing]+[CalcBW]+0.499,0)

This works as advertised, but I need to insert that report as a sub report for another report. Calculation no longer works and gives me a #Name? error. I'm sure this is simple, most of the issues that I spend hours on end up being simple.

Pauly D is offline   Reply With Quote
Old 11-25-2019, 11:19 AM   #2
theDBguy
Iím here to help
 
theDBguy's Avatar
 
Join Date: Oct 2018
Location: SunnySandyEggo
Posts: 7,279
Thanks: 63
Thanked 1,683 Times in 1,638 Posts
theDBguy has a spectacular aura about theDBguy has a spectacular aura about
Re: Subreport calculation issue

Hi Pauly,


Assuming the name of your report is "SetOC" and you're putting it in a report called "MainReport" as a subform, then this part of the expression:


[Reports]![SetOC]![UpStartFreq]


might become like this:


[Reports]![MainReport].[SetOC].Report![UpStartFreq]


Hope it helps...
__________________
Just my 2 cents...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
theDBguy is online now   Reply With Quote
Old 11-25-2019, 11:37 AM   #3
Pauly D
Newly Registered User
 
Join Date: Nov 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Pauly D is on a distinguished road
Re: Subreport calculation issue

=Round([Reports]![MissionOC].[SetOC].[Report]![UpStartFreq]+[Spacing]+[CalcBW]+0.499,0)

That did it, once I pulled my head out and realized that I had to fix the [CalcBW] cell as well. Thank you.

Pauly D is offline   Reply With Quote
Old 11-25-2019, 11:56 AM   #4
theDBguy
Iím here to help
 
theDBguy's Avatar
 
Join Date: Oct 2018
Location: SunnySandyEggo
Posts: 7,279
Thanks: 63
Thanked 1,683 Times in 1,638 Posts
theDBguy has a spectacular aura about theDBguy has a spectacular aura about
Re: Subreport calculation issue

Quote:
Originally Posted by Pauly D View Post
=Round([Reports]![MissionOC].[SetOC].[Report]![UpStartFreq]+[Spacing]+[CalcBW]+0.499,0)

That did it, once I pulled my head out and realized that I had to fix the [CalcBW] cell as well. Thank you.
Hi. You're welcome. Glad to hear you got it sorted out. Good luck with your project.

__________________
Just my 2 cents...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
theDBguy is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Subform/Subreport Issue Codex Reports 2 04-07-2014 02:30 PM
Calculation on Report using SubReport Vergy39 Reports 3 12-24-2010 12:08 PM
Trouble bringing in a calculation from main report to use in subreport PamelaJoy Reports 9 06-16-2009 03:35 AM
subreport issue dakcg Reports 1 02-19-2005 03:19 PM
Subreport Issue cable Reports 1 11-01-2004 04:10 AM




All times are GMT -8. The time now is 01:46 PM.


Microsoft Access Help
General
Tables
Queries
Forms
Reports
Macros
Modules & VBA
Theory & Practice
Access FAQs
Code Repository
Sample Databases
Video Tutorials

Featured Forum post


Sponsored Links


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
(c) copyright 2017 Access World