Flow - Email Moving problem (1 Viewer)

Minty

AWF VIP
Local time
Today, 08:11
Joined
Jul 26, 2013
Messages
9,288
Hi All, I suspect only @Isaac may know about this, but looking for clues.
I can't get a cloud Flow process to move an email in a shared general email box.

  1. The process is triggered on new email receipt. (O365 account the
  2. It then checks it not internal.
  3. If not it calls a stored procedure to look up the SentFrom email address and return the technicians inbox folder to the flow.
  4. It uses this folder to move the email to the correct technician's folder automatically.
Steps 1-3 all work step 4 fails with a error message of
"ErrorItemNotFound","originalMessage":"The specified object was not found in the store., The process failed to get the correct properties."},"source":"office365-we.azconn-we-01.p.azurewebsites.net"}}
The sp is retrieving the correct email sub folder and I'm applying like this;
1646936881147.png


This does produce the correct path to the subfolder.
I have checked permissions on the mailbox, etc and everything looks fine. In the error log it displays
Inbox/jsmith
as the folder which is correct.

I have recreated the flow from scratch and left it for 24 hours as suggested by some posts I have fouund. Totally stumped!
 

Isaac

Lifelong Learner
Local time
Today, 00:11
Joined
Mar 14, 2017
Messages
6,523
Just quit the job I had where Flows were starting to be used, and can't replicate the problem on my home computers.
Now I'm doing the most intense SQL Server (on prem) querying I've ever done - and only that, I'm afraid, with the possibility of some SSIS thrown in later, but probably not much.

Is there any chance the "not equal to null" could possibly be failing, based on your result?
I had a HELL of a time getting a simple expression like not null or null to work - let me see if I can find some of my shamefully ignorant Power Apps forum posts (solved) to help, and post back. maybe tonight. But specifically not equal or equal to null caused me a lot of problems - the solution was insane if i remember correctly.
 

Isaac

Lifelong Learner
Local time
Today, 00:11
Joined
Mar 14, 2017
Messages
6,523
 

Minty

AWF VIP
Local time
Today, 08:11
Joined
Jul 26, 2013
Messages
9,288
Bizarrely that appears to be no problem, it gets past that condition with no problem.
It just the email moving bit.

I'm tried hard coring a switch statement as a test last night and it failed with a permissions error, but I was modifying an old flow, and that doesn't seem to work very well.
I'll rewrite it from scratch on Monday. I'm off to that there London to celebrate the wife's birthday, so work is on the not thinking about it list :cool:
 

Isaac

Lifelong Learner
Local time
Today, 00:11
Joined
Mar 14, 2017
Messages
6,523
Bizarrely that appears to be no problem, it gets past that condition with no problem.
It just the email moving bit.

I'm tried hard coring a switch statement as a test last night and it failed with a permissions error, but I was modifying an old flow, and that doesn't seem to work very well.
I'll rewrite it from scratch on Monday. I'm off to that there London to celebrate the wife's birthday, so work is on the not thinking about it list :cool:

Sure hope you get it solved! I'm glad I saw this thread & subscribed to glean some knowledge from your inevitable posted solution (y)
Not an AWF nearly as much any more, relatively, and hence miss most notifications and mentions and such.

Best of luck, enjoy London and have a wonderful weekend!
 

Users who are viewing this thread

Top Bottom