Form Button vba and Combobox conditional formatting (1 Viewer)

Dewayne Davis

New member
Local time
Today, 00:58
Joined
Jul 19, 2021
Messages
4
I have a form called MATERIAL QUERY that tracks material for a specifically selected project by filtering according to selection in a combo box on the main form called HOME. There is a button on MATERIAL QUERY that closes this form and opens the HOME form. One of the combo boxes on MATERIAL QUERY selects the current status of the material line items. I have conditional formatting set up to change the color according to that status. Everything seems to work great. But occasionally when I open the database, the conditional formatting is not being applied. Also this button that closes the form does not work. When I click the event and open the VBA, it suddenly starts working again. Until some random time that I open the database and it does it again. What should I look for to find the issue here?
 

theDBguy

I’m here to help
Staff member
Local time
Yesterday, 22:58
Joined
Oct 29, 2018
Messages
18,792
Hi. Welcome to AWF!

That's very interesting. It would be hard to help you troubleshoot that without seeing it in action. It could be caused by how your computer is set up. If your code is causing it, we may have to see the code. You might try tracing any "common" actions surrounding the event when it happens to see if any particular set of actions or situations could be contributing to the problem. Otherwise, I can't think of anything specific to tell you to look out for. Good luck!
 

missinglinq

AWF VIP
Local time
Today, 01:58
Joined
Jun 20, 2003
Messages
6,424
this button that closes the form does not work. When I click the event and open the VBA, it suddenly starts working again. Until some random time that I open the database and it does it again

As the Friendly Ogre said...being able to 'lay hands' on your actual file would help us immensely in helping you! Having said that, though, if by

this button that closes the form does not work. When I click the event and open the VBA, it suddenly starts working again. Until some random time that I open the database and it does it again

you mean that after going into the VBA editor then going to Form View the button works...but simply opening the database and then opening the Form in Form View it doesn't...the problem could be that you haven't designated the folder holding the file as 'Trusted.'

To "Trust" your folder (at least in 2007/2010) click:

  • Office Button (top left)
  • Access Options (bottom of dialog)
  • Trust Center (left)
  • Trust Center Settings (button)
  • Trusted Locations (left)
  • Add new location (button)
Access will run code, when going from Design View to running it, in Form View, even with the Folder not 'trusted,' but will balk when opened directly in Form View, under the same conditions.

Linq ;0)>
 

Users who are viewing this thread

Top Bottom