Problem with imagecontrol. (1 Viewer)

John Sh

Member
Local time
Tomorrow, 10:25
Joined
Feb 8, 2021
Messages
86
I have two forms, in separate access db's, with pictures going into an image control. In the larger of the two forms the transition from record to record is quite normal with the associated picture displayed.
In the smaller form there is a brief period when the entire detail section of the form goes white. This occurs at the time the image control gets the new picture location.
The code initiating the picture display is the same for both forms but with a different path.

Code:
Me.imgPhoto.Picture = path & Me.txtPhotoNumber & ".jpg"

Before using the imagecontol in the smaller form I was calling a url to display the photo in an eternal viewer. This worked without the temporary whiteout but the image was floating and usually landed in an inappropriate place. That image also needed to be manually closed to avoid a buildup of instances of the viewer.

Any suggestions on how to fix this will be gratefully received.
I'm happy to upload the form if required.
 

arnelgp

..forever waiting... waiting for jellybean!
Local time
Tomorrow, 07:25
Joined
May 7, 2009
Messages
14,607
why not "insert" the path+image.jpg to a text field in your table.
so you only add this textbox to your form.
then set the imagecontrol ControlSource to that textbox.
 

John Sh

Member
Local time
Tomorrow, 10:25
Joined
Feb 8, 2021
Messages
86
Thanks arnelgp.
I created a "photoPath" field and bound the imagecontrol to that field. No need for the text box. It now works fine.
Here's your jellybean.
🍬 Sorry, fresh out of jellybeans.
 

Users who are viewing this thread

Top Bottom