Reference being lost repeatedly by one user (1 Viewer)

Alc

Registered User.
Local time
Today, 03:58
Joined
Mar 23, 2007
Messages
2,371
Firstly, I'm not sure that 'Modules and VBA' is the correct place for this question, but it feels the most appropriate.

Our company recently upgraded to Office 365. However, we still use Access 2010 because of this ongoing issue:
https://support.microsoft.com/en-us/topic/access-reports-that-databases-are-in-an-inconsistent-state-7ec975da-f7a9-4414-a306-d3a7c422dc1d?ui=en-us&rs=en-us&ad=us

When a user first opens a database using Access 2010 after the 365 upgrade, they get a message that GRAPH.EXE is missing from folder C:\Program Files\Microsoft Office\Office16.

This is fixed by manually copying files MSWORD.OLB, MSOUTL.OLB, MSPPT.OLB, EXCEL.EXE and GRAPH.EXE into that folder and manually refreshing the db links.
Note: All five files are missing, but GRAPH is always the one that produces the error. The other four somehow retain their mapping, even when not in the folder. I assume they'd produce an error when I tried to export to Excel or send an email.

For almost all users this method works fine, the errors go away and functionality is restored. However, one user gets the same error message every time he opens a database, even it had been fixed the previous day. The file is still definitely present in the folder but it appears that something is 'resetting' the manual mapping overnight but just for this one user. It allows me to remap it without any problems but the next day we're back to the same problem.

Is there something that could cause this and which I could change from within the db, or is this something for the IT dept?
 

Minty

AWF VIP
Local time
Today, 08:58
Joined
Jul 26, 2013
Messages
8,760
Not a specific fix, but I have seen Office updates that were incomplete, e.g. unfinished for some weird reason only known to M$.

Repeating the update or repairing the install has fixed some odd issues with office apps in general.
 

Alc

Registered User.
Local time
Today, 03:58
Joined
Mar 23, 2007
Messages
2,371
Not a specific fix, but I have seen Office updates that were incomplete, e.g. unfinished for some weird reason only known to M$.

Repeating the update or repairing the install has fixed some odd issues with office apps in general.
Thanks. I'll suggest this to the team responsible.
 

Users who are viewing this thread

Top Bottom