Paste the field names in the order you defined with the Tab Order command (1 Viewer)

tomasm

New member
Joined
Nov 20, 2017
Messages
23
If I paste multiple rows from Excel into a continuous form, and the first row copied from Excel does not contain the matching field names in the form, I receive the following prompt:

"None of the field names you pasted onto the clipboard match the field names on the form.
Access treats the data in the first row on the Clipboard as field names. If you copied the data from another application, the first row of data may have taken the place of the field names. Do you want to paste the field names in the order you defined with the Tab Order command?"

Is there a way to suppress this prompt? I want "paste the field names in the order you defined with the Tab Order command" to be the default. I can avoid this prompt by using datasheet view but I prefer to use continuous if possible.
 
The behavior you seem to want requires you to create the table with the act of importing rather than putting the names in place ahead of time. You suggested that this works in datasheet view, but the question is, when Access used datasheet view, did it get the names right when compared to what the form would have used? I.e. looking for a mismatch between explicit form settings and imported data headings.
 
Yes, pasting in continuous view or datasheet view works correctly as long as the number of columns is the same and field types are the same. The data is stored in the table that the form is bound to exactly as it should.

Now that I know datasheet column names (and other things) can be customized, I'm going to use datasheet view and don't need to worry about confusing users with that prompt or requiring them to include field names in the first row when copy pasting from Excel.
 
If that style of workaround gets you where you need to go, then great! Sometimes the direct solution isn't clearly available. But where there''s a will, there is usually a way.
 

Users who are viewing this thread

Top Bottom