Tip How to fix Google maps display issues in Access web browser control (1 Viewer)


Local time
Today, 03:35
Jan 14, 2017
A few months ago, I experienced issues displaying Google maps in an Access web browser control,

The issue was that the map loads perfectly for a second or so followed by a pop up window advising you to switch off compatibility mode.
When this is dismissed, all of the map except the outer edge disappears!

Online searches revealed that this has been a problem for many users for at least 5 years which for some reason Google & Microsoft haven't fixed.

The problem is that by default the Access web browser control is designed for IE7 which of course is out of date and no longer supported.
NOTE: It still uses IE rather than Edge...

Anyway, I found a solution involving changes to the registry which worked perfectly ...
...until this week when I had to reinstall Windows on a new hard drive.
The problem returned immediately.

Today, I tried various suggested fixes as follows before finding the registry fix once again.
I'm posting all the methods I tried as others may not need the registry fix.

1. Turn off Compatibility view
Taken from https://support.google.com/maps/answer/3118069?hl=en
Open Internet Explorer.
In the top right, click Tools. (If you don't see the icon, press the F10 key to see it.)
Click Compatibility View Settings.
Under “Websites you’ve added to Compatibility View," select google.com.
Click Remove.

As I didn't have Google listed, this clearly was no use - at least for me

2. Remove all google sites from [Trusted sites] in [Security] tab of [Internet Options]

Once again N/A for me

3. Use software rendering instead of GPU rendering in IE

Again, didn't help me - in fact it made the issue worse.

4. Update the registry so Access uses IE11 (or whichever version of IE you have on your machine)

This involves adding (or editing) the registry to make your version of IE (probably IE11) the default.
As always, the standard warning about any changes to the registry are done at your own risk

It involves 2 new keys being added to the HKEY_CURRENT_USER hive (for just you) or if preferred to HKEY_LOCAL_MACHINE (all users)
This works perfectly - at least for me ....

Open the registry then find the key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION
Right click and select New ... DWord Value ...
Enter MsAccess.exe then right click .. Modify .. Decimal and enter 11001

A quicker way is to use the attached reg file.
Unzip .. right click and select Merge
It will add the following 4 keys ... though you don't really need HKCU if you add HKLM

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl]

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_DOCUMENT_COMPATIBLE_MODE]

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl]

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_DOCUMENT_COMPATIBLE_MODE]


This can be adapted for any other program instead of MSAccess.exe or for version of IE. Here is a list of the values that you might want to use:

11001 - IE11 Edge mode
11000 - IE11 Default Mode
10001 - IE10 Standards Mode
10000 - IE10 Default Mode
9999 - IE9 Stanards Mode
9000 - IE9 Default Mode
8888 - IE8 Standards Mode
8000 - IE8 Default Mode
7000 - IE7

Hope this is of use to others and, even if not, I know where to find the solution for my own future reference!


  • GoogleMapsRegFix.zip
    463 bytes · Views: 145
  • RegFix.PNG
    55.7 KB · Views: 1,068
  • TrustedSites.jpg
    61.4 KB · Views: 1,030
  • SoftwareRendering.PNG
    24.7 KB · Views: 1,022
  • CompatabilityView.PNG
    13 KB · Views: 1,063
Last edited:


Local time
Today, 03:35
Jul 26, 2013
I had a similar issue - very frustrating.
Good write up Colin.


Local time
Today, 03:35
Jan 14, 2017
I partly did it for me ... for the next time my hard drive fails!

The irony is I had written a shorter version for my own purposes a few months back but saved it on the drive which failed!

I must start saving stuff to the cloud on a regular basis!


Longboard on the internet
Local time
Yesterday, 19:35
Sep 12, 2017
don't save to the cloud, save to this forum! That way we can all benefit from your time and effort!

Users who are viewing this thread

Top Bottom