Unable to edit text field on a Subform (1 Viewer)

zooropa67

Registered User.
Local time
Today, 22:03
Joined
Mar 19, 2013
Messages
42
I have a main form that contains a tab control with 3 tabs. On each tab is a subform and there is a "comments" text field on each subform.
On two of the subforms I can edit the contents of this text field ok. On one I can't. I've checked all the usual stuff about making sure AllowDeletions is set to Yes on each subform and that the text field is Enabled and not Locked. I've now been at this for 4 hours and nothing I've tried has worked (including adding a second subform with a different recordsource) but I still can't edit the text field. It's as if there's some kind of disconnect between the text field and the linked table (it's a split db). The recordsource is just selected from the recordsource dropdown in the data tab of the subform's properties (not created dynamically although I've tried that too with same result). Thanks in advance for any suggestions.
 

theDBguy

I’m here to help
Staff member
Local time
Today, 14:03
Joined
Oct 29, 2018
Messages
19,211
Are you able to post a demo copy of your db?
 

isladogs

CID VIP
Local time
Today, 22:03
Joined
Jan 14, 2017
Messages
16,427
Copy the record source to a query. Is that read only? If so, what is the query SQL?
 

zooropa67

Registered User.
Local time
Today, 22:03
Joined
Mar 19, 2013
Messages
42
Copy the record source to a query. Is that read only? If so, what is the query SQ

Copy the record source to a query. Is that read only? If so, what is the query SQL?
Thanks for your reply. The recordsource is a query. It's SQL is as follows:

SELECT tbl_lot.lot_id, tbl_lot_type.lot_type, tbl_lot.lot, tbl_lot.lot_comment, tbl_lot_status.lot_status, tbl_lot.number_wafers, tbl_user.my_username, tbl_lot.lot_started_timestamp
FROM tbl_user INNER JOIN ((tbl_lot_type INNER JOIN tbl_lot ON (tbl_lot_type.lot_type_id = tbl_lot.lot_type_id) AND (tbl_lot_type.lot_type_id = tbl_lot.lot_type_id)) INNER JOIN tbl_lot_status ON tbl_lot.lot_status_id = tbl_lot_status.lot_status_id) ON tbl_user.user_id = tbl_lot.started_by_user_id
WHERE tbl_lot.lot_status_id = 1
ORDER BY tbl_lot.lot_started_timestamp DESC;
 

MajP

You've got your good things, and you've got mine.
Local time
Today, 17:03
Joined
May 21, 2018
Messages
6,450
Probably need to set it to "Dynaset Inconsistent updates". You query includes two tables.
Also are you linking from primary keys (or indexed).
Inconsistent.jpg
 

Users who are viewing this thread

Top Bottom