Hyperlink not becoming hyperlink (1 Viewer)

Zydeceltico

Registered User.
Local time
Today, 07:32
Joined
Dec 5, 2017
Messages
787
Hi All,

I am havnig an issue with a hyperlink not wanting to remain a hyperlink after data entry in a form.

I have two tables we'll call Table1 and Table2. There is a field in Table1 called "Photos" which is formatted as a hyperlink datatype. If I have Table1 open I can paste a link address into a cell and everything works as expected. The link opens. These are links to folders containing job photos on our network drive btw.

The problem arises when I try to do an UPDATE from a data entry field.

The data entry process uses 3 forms. Form1, Form2, Form3: are opened in that order. Form1 and Form3 both collect data for Table1 which stays open with Pop Up = No and Modal = No.

Form2 is opened from Form1 the value of the PK of Table1 is passed to Form2.
More data is entered on Form2 that is later saved to Table2.
Before Form2 can be saved and closed Form3 must be opened and several pieces of data are entered on Form,3 also - including a hyperlink to a folder created on the fly using File Explorer. ( I just thought of a better way to do this part but I still want to answer my question.)

When Form3 is closed the following UPDATE query runs:

Code:
   Dim ctl As Control
   Dim strSQL As String
 
    strSQL = "UPDATE tblInspectionEvent " & _
        " SET Notes = '" & Me.txtNotes & "' , " & _
        " Photos = '" & Me.txtLinkToPhotos & "' , " & _
        " OilCanning = '" & Me.cboCanningYesNo & "' , " & _
        " CanningStopLine = '" & Me.cboCanningLineStop & "' , " & _
        " CoatingIssues = '" & Me.cboCoatingIssueYesNo & "' , " & _
        " CoatingStopLine = '" & Me.cboCoatingIssueLineStop & "' , " & _
        " IssuesOther = '" & Me.cboOtherIssues.Column(1) & "' " & _
        " WHERE InspectionEvent_PK = " & Me.txtInspectionEvent_ID & " ;"
       
        Debug.Print strSQL
       
   On Error GoTo Err_BeforeUpdate

All of the data transfers to Table1 just fine - no issues. If I open Table1 even the Photos field will be populated with the hyperlink address that was entered on Form3.

But if I click on it nothing happens.
If I right click the cell and got to Hyperlink>Edit Hyperlink, I see that the hyperlink value has been placed in the "Text to display" box but not in the "Address box at the bottom of the window.

Any thoughts as to why this is happening?

I have many other situations where pasting hyperlinks into data entry forms works great. All of those are single form circumstances though and don't entail a condition like using Form2.

Thanks in advance,
Tim
 

theDBguy

I’m here to help
Staff member
Local time
Today, 04:32
Joined
Oct 29, 2018
Messages
15,542
Hi Tim,

Try changing this line:
" Photos = '" & Me.txtLinkToPhotos & "' , " & _
into this:
" Photos = '#" & Me.txtLinkToPhotos & "' , " & _
 

Zydeceltico

Registered User.
Local time
Today, 07:32
Joined
Dec 5, 2017
Messages
787
Hi DBguy!

That did the trick! THX

So what exactly does the hashtag do?
 

theDBguy

I’m here to help
Staff member
Local time
Today, 04:32
Joined
Oct 29, 2018
Messages
15,542
Hi DBguy!

That did the trick! THX

So what exactly does the hashtag do?
Hi. Glad to hear you got it sorted out. A Hyperlink field has three parts separated by a hash tag. We just told Access which part we want to use/assign. Cheers!
 

Users who are viewing this thread

Top Bottom