Forms shrinking on the right edge. (1 Viewer)

freuzo

Member
Joined
Apr 14, 2020
Messages
98
Hello everyone,

I have a weird issue with my app. I use only popup forms, one main and some secondary ones. But sometimes they get cut off on the right edge. I don’t know why this happens.

For example, original form:
1680858320859.png


Shrinked:
1680858386720.png


Sometimes it doesn't even care about the buttons and eat a bit of them.
This happens to all of my forms and, desperate, I add some extra space on the right side to give ms access something to chew.

What to you guys think ?
 
you can manually resize your form when it loads:
Code:
Private Sub Form_Open(Cancel As Integer)
    ' 4 inches wide
    DoCmd.MoveSize , , 4 * 1440
End Sub
 
Yes, but I'll have to do that in everyone of my forms. They have differents sizes.
 
oh, what is your form, Single Form or Split Form?
use single form.
 
Mostly single forms. Some have subforms in continuous view.
If there is no other solution, I guess I'll have to standardize my forms height and width.
 
you need to do this on all your form.
on design view, click on the X button and on the Ribbon->Arrange->Table->Stacked.
now Insert->Right, and reduce/the size of the "EmptyCell".
drag the right side so it touches the "EmptyCell".
save your form.
 
Thanks. I hope this works because one time I added a empty textbox to "block" the shrinking but the textbox was also chewed.
 
Normally to fix this problem, you would size the form in design mode. Then open it normally and move it to where you want it to open. Then press the size to fit button and save. If you can press the resize button from the popup, then open the popup normally ONE time and press the resize and save.

If you don't need to scroll the form, don't forget to turn off the scroll bars.
 
Just curious, is the Form's Auto Resize property set to Yes?
 
Normally to fix this problem, you would size the form in design mode. Then open it normally and move it to where you want it to open. Then press the size to fit button and save. If you can press the resize button from the popup, then open the popup normally ONE time and press the resize and save.

If you don't need to scroll the form, don't forget to turn off the scroll bars.
I read that somewhere and tried (opened form, resized, saved, scrollbars disabled, etc.)
All of these fixes the problem for a while but it always comes back. Today it came back to my main form, yet I haven't changed anything on this form for several weeks.
 
Just in case it may be of some help:

I also use popup forms primarily. I found that I'd size my form to a certain size in Design View. Then in Form View it would show wider. The problem was resolved when I set the Scroll Bars property to Neither. This is because Access seems to add space for the scroll bars.

I hope you find a solution to your problem.
 
The problem was resolved when I set the Scroll Bars property to Neither.
That's exactly why I suggested turning them off when you don't need them.

Welcome aboard:)
 

Users who are viewing this thread

Top Bottom