Report image not appearing in Print Preview (1 Viewer)

Kayleigh

Member
Local time
Today, 05:04
Joined
Sep 24, 2020
Messages
709
Hi there,

I have a report which has an image in the header. It will appear no problem in the layout and report view. But not in Print Preview or if output to PDF.
Tried compressing image, resizing, convert to JPG etc. Nothing seems to help. This is on MS Access 2016

However it works okay on MS Access 365.

Any ideas how to resolve this?
 

GinaWhipp

AWF VIP
Local time
Today, 00:04
Joined
Jun 21, 2011
Messages
5,899
I switched to PNG and that problem disappeared. You can see if it works for you.
 

Kayleigh

Member
Local time
Today, 05:04
Joined
Sep 24, 2020
Messages
709
Unfortunately i have tried JPG, PNG and BMP with no success.
 

GinaWhipp

AWF VIP
Local time
Today, 00:04
Joined
Jun 21, 2011
Messages
5,899
Just had another thought, is the image set to Zoom or Clip?
 

isladogs

MVP / VIP
Local time
Today, 05:04
Joined
Jan 14, 2017
Messages
18,269
Check the Display When property for the image is set to Always

1693858029404.png


If its Screen Only it won't appear in Print Preview. If its Print Only, it won't appear in Report View
 

Kayleigh

Member
Local time
Today, 05:04
Joined
Sep 24, 2020
Messages
709
Both image and section is set to 'Always'. And I have tried it not clipped/zoomed. Still no luck☹️
 

GinaWhipp

AWF VIP
Local time
Today, 00:04
Joined
Jun 21, 2011
Messages
5,899
Hmm, let's try this. Put a red border around the picture. When you preview the report do you see the red border?
 

Kayleigh

Member
Local time
Today, 05:04
Joined
Sep 24, 2020
Messages
709
Yes - see attached
 

Attachments

  • Screenshot 2023-09-06 104016.png
    Screenshot 2023-09-06 104016.png
    44.9 KB · Views: 77

GinaWhipp

AWF VIP
Local time
Today, 00:04
Joined
Jun 21, 2011
Messages
5,899
Sorry for delay got caught up.

Seeing the red border tells me the image is there but not displaying. What is the width and height of the actual image? If it is bigger than your control resize to the size of your control and try again.
 

Kayleigh

Member
Local time
Today, 05:04
Joined
Sep 24, 2020
Messages
709
This is a really weird issue because it works on some users PCs and not on others. Generally it works on later versions of Office but one user has Office 2016 but doesn't display. No idea what could be causing this 🤷‍♀️
 

GinaWhipp

AWF VIP
Local time
Today, 00:04
Joined
Jun 21, 2011
Messages
5,899
Hmm, sounds like there could be a bug with the version that was fixed in later versions.
 

Users who are viewing this thread

Top Bottom