Site changed to secure (1 Viewer)

CJ_London

Super Moderator
Staff member
Local time
Today, 00:15
Joined
Feb 19, 2013
Messages
16,668
this is editing my last post

return is working
 

CJ_London

Super Moderator
Staff member
Local time
Today, 00:15
Joined
Feb 19, 2013
Messages
16,668
but editing is not - just returns a blank form which completely overwrites what was there before
 

pbaldy

Wino Moderator
Staff member
Local time
Yesterday, 16:15
Joined
Aug 30, 2003
Messages
36,133
I was able to edit my post above without problems, or am I misunderstanding?
 

Jon

Access World Site Owner
Staff member
Local time
Today, 00:15
Joined
Sep 28, 1999
Messages
7,459
well I can edit your post as well Jon - but overwrites what you had here before
 
Last edited by a moderator:

CJ_London

Super Moderator
Staff member
Local time
Today, 00:15
Joined
Feb 19, 2013
Messages
16,668
@Jon I was able to edit your post, but that may be due to moderator rights. But when I try to edit, I get a blank form area. I would attach an image but I can't upload anything at the moment:(
 

CJ_London

Super Moderator
Staff member
Local time
Today, 00:15
Joined
Feb 19, 2013
Messages
16,668
previous entries were using IE11, this is from Chrome - seems I can upload files via Chrome

This is what I see in IE11 - no text to edit
 

Attachments

  • Capture.JPG
    Capture.JPG
    35.1 KB · Views: 462

CJ_London

Super Moderator
Staff member
Local time
Today, 00:15
Joined
Feb 19, 2013
Messages
16,668
looks like it's OK on Firefox as well, so a problem with IE11?

I'll just try Edge
 

Jon

Access World Site Owner
Staff member
Local time
Today, 00:15
Joined
Sep 28, 1999
Messages
7,459
Try clearing your cache in IE11.
 

Frothingslosh

Premier Pale Stale Ale
Local time
Yesterday, 19:15
Joined
Oct 17, 2012
Messages
3,276
I think it's an IE11 problem. Everything works fine here on Chrome (including editing, highlighting, etc), but my work PC uses IE11 and I have all sorts of issues here with it.
 

CJ_London

Super Moderator
Staff member
Local time
Today, 00:15
Joined
Feb 19, 2013
Messages
16,668
Try clearing your cache in IE11.
tried that and no effect.

The only way I can get uploads to work in IE11 is to click on the 'Show All Content Button'

I'll see if I can edit this now

... yes I can, if I click the 'show all content' button
 

CJ_London

Super Moderator
Staff member
Local time
Today, 00:15
Joined
Feb 19, 2013
Messages
16,668
found a solution - the message bar comes up because

This message is telling you that there may be both secure and non-secure content on the page. Secure and non-secure content, or mixed content, means that a webpage is trying to display elements using both secure (HTTPS/SSL) and non-secure (HTTP) web server connections. This often happens with online stores or financial sites that display images, banners, or scripts that are coming from a server that is not secured. The risk of displaying mixed content is that a non-secure webpage or script might be able to access information from the secure content.

Going to Internet Options>Security>Customer Level, then scrolling down to Miscellaneous and finally to Display Mixed Content - mine was set to Prompt and I changed to Disable then saved and exited IE11.

When next coming back to the forum I had to log in again, but the message has gone and everything seems to work OK - and no advertising at the top - so suspect that is what is causing the issue
 

Jon

Access World Site Owner
Staff member
Local time
Today, 00:15
Joined
Sep 28, 1999
Messages
7,459
I can tell you what the issue may be. When you have an https site, the browser wants ALL the links on the page to be https, not http. So, people who have signature links that are http, they will cause a problem.

ACTION POINT: I encourage all people with http signature links to change to https if at all possible. Your site may need to be adjusted for https. The reason is that some browsers may suffer this issue as it is then deemed Mixed Content (i.e. secure and unsecure links on the same page). Also, for visitors from searching on Google, they will not find the threads so well that are unsecure, as Google applies a penalty in their algo to pages that are not https.

This situation is likely to become more prominent over time, as Google increasingly applies pressure to make the web secure.
 

Rx_

Nothing In Moderation
Local time
Yesterday, 17:15
Joined
Oct 22, 2009
Messages
2,803
On win 10 - IE - never noticed any problems - have yet to attempt upload.
If it makes any difference, Denver is a Mile High - that implies our OS are not Metric.
Thanks for all you do Jon!
 

pbaldy

Wino Moderator
Staff member
Local time
Yesterday, 16:15
Joined
Aug 30, 2003
Messages
36,133
In my experience you only get the secure site if you follow the link from an email notification or type the "s" in yourself. Otherwise you still get the non-secure site.
 

Jon

Access World Site Owner
Staff member
Local time
Today, 00:15
Joined
Sep 28, 1999
Messages
7,459
@pbalby, this is likely to change. Its going to take some time to get this all sorted properly.
 

Jon

Access World Site Owner
Staff member
Local time
Today, 00:15
Joined
Sep 28, 1999
Messages
7,459
Slowly getting there. Managed to get the green padlock showing in my Chrome browser earlier, after getting rid of some offending links. Just need to figure out some htaccess code modifications and the site should be secure and good to go!

Before, I thought that signature links with http rather than https would cause a problem. But now I don't think that is the case. Its urls that call stuff while the page is loading that are the offending targets, rather than links that are just displayed.
 

pbaldy

Wino Moderator
Staff member
Local time
Yesterday, 16:15
Joined
Aug 30, 2003
Messages
36,133
Good news, because links in posts would have also caused a problem, and you have no control over what links people post (well, you might, but...). We're often posting a link to the answer, rather than recreating the answer, and most of those sites aren't secured.
 

Jon

Access World Site Owner
Staff member
Local time
Today, 00:15
Joined
Sep 28, 1999
Messages
7,459
Welcome to the new secure site!

You will now notice a green padlock at the top left of the browser in your address bar and on Chrome it will also show the words Secure. It took a while but I got there in the end!
 

Users who are viewing this thread

Top Bottom